2015年12月

ubuntu 提示权限不足

更改可以不用切换用户登陆的。
sudo -i
获取root权限。
如果这样权限还是不够,
那就输入sudo passwd然后输入两次密码,这个就是修改好的root密码。
然后在输入
su root
输入修改好的root密码就获取root权限了。
修改文件终端用gedit命令或者gvim这样的图形化文本编辑器,会比较方便。
ubuntu默认是不允许root用户登陆图形界面。

来自:http://zhidao.baidu.com/link?url=9Kt0MqYm9ZEikihb5AlwKtBp49FDufjc9ve8O_OMMpkN3w-nkgokzxpW6PvtiQgZcGEzEJeyxyr8sdocffYdEYTd2tBbXHpID3AtrG3OfaS

Linux vi退出保存指令

按ESC键 跳到命令模式,然后:

:w 保存文件但不退出vi
:w file 将修改另外保存到file中,不退出vi
:w! 强制保存,不推出vi
:wq 保存文件并退出vi
:wq! 强制保存文件,并退出vi
q: 不保存文件,退出vi
:q! 不保存文件,强制退出vi
:e! 放弃所有修改,从上次保存文件开始再编辑

来自:http://zhidao.baidu.com/link?url=EL5OvaSRY1EUJgsqOqv6T1DFU0fB7WnwSCHPIR2sS5T2EuNFDEepAQHXOv5Xtb6h0bmkvCVVa8J5TH9mqFLqh_

CentOs 5.8使用epel源出现问题

[root@VM_139_54_centos ~]# rpm -ivh epel-release-6-8.noarch.rpm
warning: epel-release-6-8.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key
ID 0608b895
error: Failed dependencies:

    rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-8.noarch
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-8.noarch

使用rpm -ivh epel-release-6-8.noarch.rpm 的时候提示我的rpm库版本太低。
既然这样,那我就更新下:yum update rpm*
更新完成后还是提示我版本过低。
后来才知道是因为我这是5.8的,不能使用epel 6.8的,换成5.4的即可。如下:
32位:
rpm -ivh http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-5
64位:
rpm -ivh http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-5